When i try to create reports (pdf reports) there is an unknown charset there.

http://itmages.ru/image/view/4711230/3900a33e

asked 10 Aug '16, 07:28

kele6ra's gravatar image

kele6ra
21147
accept rate: 9%

edited 22 Dec '16, 10:27

caseydk's gravatar image

caseydk ♦♦
717243347


which report? at least a few work fine on German computer (Win 10 standard) I don't need/try all of them
permanent link

answered 10 Aug '16, 10:46

opto's gravatar image

opto ♦
8133969129
accept rate: 10%

answered 10 Aug '16, 10:46

I find this problem on all pdf reports =(
permanent link

answered 10 Aug '16, 12:02

kele6ra's gravatar image

kele6ra
21147
accept rate: 9%

answered 10 Aug '16, 12:02

I found that it writes symbols to db not in utf8, but in latin1 and somehow show it in utf8 again in all html views. But when it creates a pdf report it use latin1 again. Database in utf8 and shows symbols not correct.
permanent link

answered 11 Aug '16, 01:37

kele6ra's gravatar image

kele6ra
21147
accept rate: 9%

answered 11 Aug '16, 01:37

I noticed a similiar problem here. It is Mysql related.\nThere is a DB encoding and a connection encoding and a browser encoding. Setting the connection encoding did not work. In trial and error, I needed a weird combination of browser encoding (w2p) and connection encoding to display all correctly. That happened only on a specific version of Mysql5.5 Klaus
permanent link

answered 11 Aug '16, 21:04

opto's gravatar image

opto ♦
8133969129
accept rate: 10%

answered 11 Aug '16, 21:04

mysql> select version();\nversion()\n5.6.24-2+deb.sury.org~precise+2 How can i solve this problem?
permanent link

answered 12 Aug '16, 01:45

kele6ra's gravatar image

kele6ra
21147
accept rate: 9%

edited 12 Aug '16, 01:46

I rans a full search in Eclipse. The base install of W2P uses Latin 1 as default character set in quite a few places. - /opt/web2project/install/sql/001_base_install.sql - /opt/web2project/install/sql/021_contact_methods.sql - /opt/web2project/lib/adodb/drivers/adodb-mysqli.inc.php The last one could be significant. Again, I will try changing the default from latin 1 to utf-8 & see what happens in a new install. Cheers, Sasquatch
permanent link

answered 13 Aug '16, 06:19

sasquatch58's gravatar image

sasquatch58
211133
accept rate: 11%

answered 13 Aug '16, 06:19

Correction - the initial character set is changed in a later sql script to utf8_general_ci /opt/web2project/install/sql/006_special_characters.sql

(13 Aug '16, 07:10) sasquatch58 sasquatch58's gravatar image

Hi Sasquatch ... good that you found that - I didn't when I found the workaround for our system. If you find a fix, I will put it into 3.4pre. This may be especially complicated for db's (like ours) dating back to dP, where these settings are really inconsistent. Klaus

(14 Aug '16, 13:24) opto ♦ opto's gravatar image
hello again, did you find something with this issue? Database is sending in utf8 data to report module now, but encoding problem isn't gone.
permanent link

answered 09 Nov '16, 08:24

kele6ra's gravatar image

kele6ra
21147
accept rate: 9%

answered 09 Nov '16, 08:24

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×6
×1
×1
×1

question asked: 10 Aug '16, 07:28

question was seen: 404 times

last updated: 22 Dec '16, 10:27

powered by Bitnami OSQA