Dear Support I have an CentOS Linux v7.2.1511 platform (MySQL v5.6.28), I'm trying to reinstall W2P, but cannot login after the clean install.\nIt was working, but after last OS update, and a clean reinstall of W2P, it fails to allow admin user (or any other user) to login. I can see that all the files were created well on the SQL server. Kind regards, JC

asked 25 Jan '16, 09:56

joao.brazuna's gravatar image

joao.brazuna
11222
accept rate: 25%

asked 25 Jan '16, 09:56


Dear Support, Just found out a way to solve the problem: - Changing \"Session Handling Settings\" on system configuration from \"web2Project extended sessions\" to \"PHP Default\" It seems that this configuration is incompatible with CentOS Linux v7.2.1511. Many Thanks to all. JC
permanent link

answered 28 Jan '16, 12:52

joao.brazuna's gravatar image

joao.brazuna
11222
accept rate: 25%

answered 28 Jan '16, 12:52

Did you import the old database into the new installation? If no, try with \"admin\" and password \"passwd\". If you DID import the old database to the new installation or used the old database and cannot login, try this: - open phpmyadmin and select the new database - Find table \"users\" - Find the record of \"admin\" (usually user_id=1) - Open the SQL Tab of phpmyadmin - Enter the following: UPDATE users SET user_password=MD5('NEW PASSWORD HERE') WHERE user_id = 1; Then, try to login again. Tell me if it worked...
permanent link

answered 26 Jan '16, 10:20

Themoulos's gravatar image

Themoulos ♦
21791321
accept rate: 22%

edited 26 Jan '16, 10:24

Dear Sir, Thank you VERY much for you answer, but it did not worked.(UPDATE users SET user_password=MD5('password') WHERE user_id = 1;) The problem occurs after a clean instalation.\nIt works well if I use XAMP on my PC, but fails on a server with CentOS Linux v7.2.1511 platform (MySQL v5.6.28).\nCan it be some kind of problem with session control? Many Thanks\nJC
permanent link

answered 26 Jan '16, 10:38

joao.brazuna's gravatar image

joao.brazuna
11222
accept rate: 25%

answered 26 Jan '16, 10:38

What exactly is the error message you get? If you get a red \"X Login Failed\" error, I would guess it is a password problem.\nI am not very experienced in the OS server side, only in SQL and a little bit in php, so I cannot help any further. Just check that the user_name is \"Admin\", the user_id is 1 and the password is what you have copied-pasted in \"password\" in your command.\nI don't know exactly the OS of the server, only that MySQL is 5.7 and the server settings are as in the .PDF file following.[link text][1] [1]: /storage/temp/303-linux44papakigr-8443-smb-web-settings-id-1276.pdf
permanent link

answered 26 Jan '16, 15:59

Themoulos's gravatar image

Themoulos ♦
21791321
accept rate: 22%

answered 26 Jan '16, 15:59

Dear Sir, Once again, thank you VERY much for your time in trying to help me with this problem. I get no answer from the server after login in, as if the user or passwword were incorrect.\nI do not think that is MySQL access to the DB 'cos I can change the login window header.\n![alt text][1] If I use the function to create a user from the login page \"I want to signup for a new account please.\", nothing happens also after clicking the \"sign me up!\" button.\nIn this case, no user is created in the DB. On the users table, there is only the following record: REPLACE INTO `users` VALUES (1, 'admin', '$2y$10$ZrKnWjIlsSdW3MqdKPbCke24TFJrXRJUXMrY7yamz2HzBxMe.F8Ya', 0, 1, '', 0, 0, 0); Please note, that if I do the same operations on a XAMP environment, every thinks works ok. Many Thanks JC [1]: /storage/temp/306-capturar.png
permanent link

answered 27 Jan '16, 05:46

joao.brazuna's gravatar image

joao.brazuna
11222
accept rate: 25%

answered 27 Jan '16, 05:46

Joao, How did you resolve this. I looked for the session handling settings and couldn't find it. I'm experiencing the same issues and this.

Thanks,

permanent link

answered 25 Apr, 08:56

johnwbond's gravatar image

johnwbond
1013
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1
×1

question asked: 25 Jan '16, 09:56

question was seen: 1,380 times

last updated: 25 Apr, 08:56

Related questions

powered by Bitnami OSQA