When I add a task as new and set the time, and save the task. In project view it adds 5 hours to the task time. In ordinary time (not daylight savings) I am 5 hours behind Greenwich mean time. Is that what I am seeing? and how do I fix that? All preferences are set to \"Chicago\" time zone, which i am in. Please see attachments.![alt text][1] [1]: /storage/temp/276-test-task1-add.png

asked 24 Jul '15, 16:41

gwildgoose's gravatar image

gwildgoose
2082026
accept rate: 0%

asked 24 Jul '15, 16:41


12next »

SOLVED!!!\nJust go to classes->Output->HTMLHelper.class.php, line 210 and change all of \"case '_date' with this: ================================================================ case '_date': $myDate = intval($value) ? new w2p_Utilities_Date($this->AppUI->formatTZAwareTime($value, '%Y-%m-%d %T')) : null; $cell = $myDate ? $myDate->format($this->dtf) : '-'; break; ================================================================= It works in my installation. Please check and verify in your installation as well... BTW, it fixes all such occurances, that did not take the user Time Zone into account, when they are displayed in tables and cells.
permanent link

answered 29 Jul '15, 17:58

Themoulos's gravatar image

Themoulos ♦
21791521
accept rate: 22%

edited 29 Jul '15, 18:01

I'm having the same problem in our production system. I am trying to troubleshoot in a test system, but not having any luck getting it running. Keep hitting one roadblock after another.
permanent link

answered 29 Jul '15, 12:21

mckinnej's gravatar image

mckinnej
102612
accept rate: 0%

answered 29 Jul '15, 12:21

Yes, the timezone conversion was left out. I made a bugfix and will upload that tomorrow to my github account.\nI will post here which branch should be used (not master, that is identical to main w2p and has the same bug). Klaus
permanent link

answered 29 Jul '15, 16:24

opto's gravatar image

opto ♦
82341104131
accept rate: 10%

edited 29 Jul '15, 16:26

Thanks for posting that. For all who don't want to touch the code, here is a bugfixed Version: go to\nhttps://github.com/opto/web2project/tree/w2p_opto_after3.3.66 and use the download zip button on the right Screen side, or use git to download. Or choose branch w2p_opto_after3.3.66 from https://github.com/opto/web2project This also fixes the issue that only template Projects can be imported. Now all Projects are available. I think Keith has a usage case why he excludes all except templates but for us that is no good workflow. Klaus
permanent link

answered 30 Jul '15, 02:26

opto's gravatar image

opto ♦
82341104131
accept rate: 10%

answered 30 Jul '15, 02:26

I believe Keith is right about importing projects, meaning that ONLY templates should be selectable. Under ideal conditions, we should be able to select which \"portions\" of the template project tasks will be imported, e.g. the contacts (yes/no)? the files (yes/no)? the links (yes/no)?\nAny suggestions regarding the \"portions\"????
permanent link

answered 30 Jul '15, 06:00

Themoulos's gravatar image

Themoulos ♦
21791521
accept rate: 22%

answered 30 Jul '15, 06:00

no, to be able to import only templates is impractical in many situations. Consider I finished a Project and the next customer wants the same. How do I do this with current w2p: go to project, which has the status finished. Convert Status to template. Import to new project. Afterwards: Don't Forget to set original project's Status back to finished. That is a very error prone workflow. In order to copy something (here: Import), I should not be forced to modify that what is to be copied. Actually, we had my workflow for years, until one of Keith's customers had so many Projects that the Dropdown took too Long to fill. Since then it is changed.\nI consider the template only approach a considerable risk for employees to mess up the Project statuses, if they are not careful. In the end, what is missing are decent copy routines (which, to be honest, I could have written over many years that I am here, but never found time ...). Concerning portions: yes, also include files, user priorities, links and many more, and the possibility to import only some of the Tasks ... .\nCurrently, we Need to Import all and then delete the wrong ones in projectdesigner ... Klaus
permanent link

answered 30 Jul '15, 07:26

opto's gravatar image

opto ♦
82341104131
accept rate: 10%

answered 30 Jul '15, 07:26

Worked Perfectly...thank so much...great job.
permanent link

answered 03 Aug '15, 11:41

gwildgoose's gravatar image

gwildgoose
2082026
accept rate: 0%

answered 03 Aug '15, 11:41

This worked for us as well. Thanks. However, there appear to other bugs hiding in the background. When we create a dependent task, rather than tying the start time to the end of the previous task, it seems to inconsistently set the start time to like 11am rather than 8am. We're having problems creating a new project from a template too. The task dates seem to get scrambled to a certain extent. The first few tasks seem to come over correctly, but then the start times will change which bonks up the end times. We pretty much are forced to manually fix the date/times on almost every task. It's a serious pain and time waster, especially when we're looking at creating dozens of projects. I saw the discussion between the devs that seem to be related to these problems. Hoping for quick and easy fixes. :)
permanent link

answered 04 Aug '15, 14:14

mckinnej's gravatar image

mckinnej
102612
accept rate: 0%

answered 04 Aug '15, 14:14

@ Mckinnej - Just out of curiosity, Don't you have to change all the dates when you load the Template project anyway? I also have a template project file set up but when I load the template, all the dates for the new project have to be changed. I cannot imagine a project where I wouldn't have to change the dates. What version are you running?
permanent link

answered 04 Aug '15, 15:04

gwildgoose's gravatar image

gwildgoose
2082026
accept rate: 0%

answered 04 Aug '15, 15:04

@gwildgoose. No, when it works right, you pick the start date and it calculates the rest based on the durations from the template. Like I said before, it \"almost\" works now. It just gets lost somewhere along the way. Currently we're running 3.3.66, but we've pulled in some fixes from master along the way. We used to have an old w2p install (probably very old, like pre-3.0 best I can remember) that seemed to work pretty well. I don't remember having this problem anyway. In this instance it makes me wish for a \"whole days only\" mode because the hours are where it seems to get lost. Come to think of it, that wouldn't be a bad option. For almost every project I've been on, tasks are defined in days. Even if w2p still used hours in the calculations, I don't need to see them. Obviously that wouldn't apply to everyone everywhere.
permanent link

answered 04 Aug '15, 15:36

mckinnej's gravatar image

mckinnej
102612
accept rate: 0%

answered 04 Aug '15, 15:36

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×12
×3

question asked: 24 Jul '15, 16:41

question was seen: 709 times

last updated: 05 Aug '15, 14:12

powered by Bitnami OSQA