After uploading the complete folder into the root directory of my site, I browsed to the site at www.we-weave.com/web2project/install but I only a blank screen loaded. After setting the error reporting to show errors this was what displayed. Warning: require_once(__DIR__/composer/autoload_real.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/w/e/e/weevil/html/web2project/vendor/autoload.php on line 5 Fatal error: require_once() [function.require]: Failed opening required '__DIR__/composer/autoload_real.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/w/e/e/weevil/html/web2project/vendor/autoload.php on line 5

asked 07 Apr '15, 20:41

weeviljae's gravatar image

weeviljae
011
accept rate: 0%

asked 07 Apr '15, 20:41

What version are you trying to install? The latest from Master or the download or the 4.0 development branch?

(10 Apr '15, 15:31) caseydk ♦♦ caseydk's gravatar image

For anyone else who bumps into this issue...

The v4.0 development branch uses Composer to manage dependencies. It is the standard dependency manager used by the general PHP community. To resolve this specific issue, after uploading web2project v4.x to your server, you'll need to use SSH, go into your base web2project directory, and run composer install or your equivalent command. Composer will install the dependencies.

That said, I recommend that you do not use the v4.0 development branch. I will be reviewing it and merging some things in the core system but that branch as a whole will be a dead end.

permanent link

answered 29 Dec '16, 11:01

caseydk's gravatar image

caseydk ♦♦
717243046
accept rate: 31%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

question asked: 07 Apr '15, 20:41

question was seen: 257 times

last updated: 29 Dec '16, 11:01

Related questions

powered by Bitnami OSQA