Hi, after updating i seems everything looks fine.\nBut now, we got some problems with editing or creating projects or new tasks.\nAfter clicking \"new task\" the fist window \"details\" looks like usual.\nBut after clicking the other tabs (dates, dependencies...) the screen is empty(attached screenshot). What's wrong? any problems with permissions to the database? We got no errors after installing the new version and using a dump of the old mysql database.\nsysadmin.updating is also executed without getting errors. ![alt text][1] best regards,\nOliver [1]: /storage/temp/192-web2project_new_task.png

asked 04 Sep '14, 03:32

oliver's gravatar image

oliver
2151114
accept rate: 33%

asked 04 Sep '14, 03:32

What do your web server error logs show for these screens?nThese are usually a good guide as to where the problem originates. Cheers, Sasquatch

(04 Sep '14, 04:04) sasquatch58 sasquatch58's gravatar image

I think, problem is solved. There was an old \"holiday\" module installed, which generates php errors. after removing the module, everything works perfect :) Sers,\nOliver
permanent link

answered 04 Sep '14, 08:46

oliver's gravatar image

oliver
2151114
accept rate: 33%

answered 04 Sep '14, 08:46

the error logs told me nothing special. We're currently investigating the error logs. But we found an other issue. Obviously there are many old php function used in the code.\nwe got many warning in the php error log. It could be, if a php update is necessary at the webserver, we gonna get big trouble because the old function. Sers, Oliver
permanent link

answered 04 Sep '14, 04:49

oliver's gravatar image

oliver
2151114
accept rate: 33%

answered 04 Sep '14, 04:49

The Readme file for W2P 3.2 states that PHP version should be better than 5.3.8\nThis is a step up from what 2.4 would run under as a minimum.\nThere may be old php code in w2p but the issue is the new code that needs the up to date version.\nRun up a test server, copy over your database and see how the V3.2 runs. Cheers, Sasquatch
permanent link

answered 04 Sep '14, 05:02

sasquatch58's gravatar image

sasquatch58
211133
accept rate: 11%

answered 04 Sep '14, 05:02

currently here is PHP Version 5.3.10-1ubuntu3.13 running...

(04 Sep '14, 05:19) oliver oliver's gravatar image
It's interesting, with using a new database, version 3.2 is running perfectly.\nBut with the old database from 2.4, there are these issues. With running a debugger, i got javascript errors and internal server errors http/1.0 500, just when clicking \"new task\" with 3.2 and the old database. With new created database, no errors. I checked this also with 3.1 -> same thing, also not working. Has anybody running a 3.2 with an imported old database? best regards,\nOliver
permanent link

answered 04 Sep '14, 08:21

oliver's gravatar image

oliver
2151114
accept rate: 33%

answered 04 Sep '14, 08:21

The holiday module for 2.4 needed updates for use under v3 & upwards.\nI've been tweaking this but a few minor fixes to go.\nHave a look on github under sasquatch58. Cheers Sasquatch
permanent link

answered 04 Sep '14, 12:00

sasquatch58's gravatar image

sasquatch58
211133
accept rate: 11%

answered 04 Sep '14, 12:00

Hi, i was wrong with telling you that everything works fine..., there are still many other issues. for example, expanding or collapsing parent/child tasks in task view or project designer view doesn't work properly. collapsing a parent tool jumps in the normal task view and leaves the project designer. Or many calculations (finish times, durations...) are wrong...Same thing for dependencies. At some tasks it works fine, at other tasks not. No idea why.\nOr an other thing: looking at the project designer at a task in the task list and see a duration which is different to the duration at the gantt chart for the same task... it's a pity, i don't know if i'm using this tool wrong, or the tool is too buggy. cheers,\nOliver
permanent link

answered 04 Sep '14, 16:16

oliver's gravatar image

oliver
2151114
accept rate: 33%

answered 04 Sep '14, 16:16

I haven't been playing with the current release but in terms of task start and stop times, earlier TZ (timezone) handling had a lot of errors in it resulting in incorrect times stored in the database. This was very evident if you changed time zones as user. This has been corrected in latest versions.\nYou will see errors of an hour or two in the display of tasks if you have imported tasks created under V2.4 for viewing in V3.2. Cheers, Sasquatch
permanent link

answered 05 Sep '14, 05:37

sasquatch58's gravatar image

sasquatch58
211133
accept rate: 11%

answered 05 Sep '14, 05:37

Thanks, i'll have a look, if it will also occur at new projects generated with 3.2 best regards,nOliver

(05 Sep '14, 05:47) oliver oliver's gravatar image
All task date/ time entries should be converted from user space (your TZ) to UTC for storing in the database.\nEarlier versions used GMT as database reference but this changes with daylight savings and depending on where your TZ was with respect to GMT you could be +/- 1h shifts over time as daylight saving transitioned in London or at your TZ.\nLook at it like this, you set a meeting task in your TZ (say Berlin) for 1200h (CEST), if I access w2p to check, then I should see that meeting in my TZ as 2200h (NZST). The database that either of us might access will have the time stored as 1000h (UTC). Much more fun when you get to change days as well for the user TZ but the database is consistent at UTC. But as Opto points out in other posts there may be other issues as well. Cheers, Sasquatch
permanent link

answered 05 Sep '14, 06:01

sasquatch58's gravatar image

sasquatch58
211133
accept rate: 11%

answered 05 Sep '14, 06:01

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×7
×2

question asked: 04 Sep '14, 03:32

question was seen: 490 times

last updated: 05 Sep '14, 06:01

powered by Bitnami OSQA